Home

compat PHP packages

49 PHP Packages found for compat | Latest compat packages | RSS

ircmaxell/password-compat

A compatibility library for the proposed simplified password hashing algorithm: https://wiki.php.net/rfc/password_hash

  • 321
  • 304
  • 12791
  • 2099
  • 425

symfony/polyfill-util

Symfony utilities for portability of PHP codes

  • 1075
  • 13
  • 43896
  • 1105
  • 0

packfire/php5.3-compat

Provides class and interface compatibility between PHP 5.3 and PHP 5.4 through autoloading.

  • 4472
  • 3
  • 19
  • 2
  • 0

joomla/compat

Joomla Compat Package

  • 4847
  • 6
  • 35
  • 0
  • 6

eloquent/pbkdf2-compat

A compatibility library for the PHP 5.5 function hash_pbkdf2().

  • 5683
  • 2
  • 26
  • 14
  • 0

symfony/polyfill

Symfony polyfills backporting features to lower PHP versions

  • 5751
  • 21
  • 426
  • 392
  • 69

rych/hash_pbkdf2-compat

Provides hash_pbkdf2() to PHP versions >=5.3,<5.5.

  • 6572
  • 19
  • 31
  • 6
  • 2

indigophp/hash-compat

Backports hash_* functionality to older PHP versions

  • 12374
  • 22
  • 91
  • 16
  • 1

contaoblackforest/contao-compat

Compat layer to work around differences in the Contao 2 and Contao 3 API.

  • 14262
  • 2
  • 1
  • 0
  • 1

imnotjames/curlfile-compat

Compatibility library with CURLFile from PHP 5.5

  • 16447
  • 2
  • 2
  • 2
  • 1

assertchris/hash-compat

Provides forward compatibility with the hash_* functions that ship with PHP 5.5

  • 16722
  • 3
  • 61
  • 0
  • 1

mattbit/mysql-compat

Backward compatibility for old mysql_* functions with PDO

  • 20270
  • 0
  • 3
  • 10
  • 5

michaelc/intdiv-compat

A compatibility library for the simplified intdiv function in PHP 7: https://wiki.php.net/rfc/intdiv

  • 20784
  • 1
  • 5
  • 4
  • 1

fisharebest/php-polyfill

Polyfills for PHP 5.3 onwards

  • 22131
  • 1
  • 3
  • 4
  • 1

ducks-project/apache

PHP polyfill for the Apache Functions. The aim is to provides functions as the PHP way in order to get them available even if PHP is not running as an Apache module.

  • 27730
  • 2
  • 1
  • 2
  • 0

crodas/phpunit-compat

Hack to get unit tests for PHPUnit 5.x running in PHPUnit 6.x

  • 34074
  • 12
  • 6
  • 0
  • 0

narf/hash_hkdf_compat

hash_hkdf() compat package

  • 34989
  • 0
  • 3
  • 5
  • 2

ayesh/is_countable-polyfill

A trivial but working polyfill for PHP 7.3 is_countable function. Supports PHP versions >= 5.3

  • 44685
  • 1
  • 67
  • 16
  • 1

phpunitgoodpractices/polyfill

Lacking future-compat polyfills for PHPUnit.

  • 45611
  • 3
  • 65
  • 0
  • 0

legalthings/base58-compat

Userspace function as fallback for base58 extension

  • 50368
  • 2
  • 1
  • 0
  • 0

wirecard/magento2-ee-compat

Magento2 compatibility package for Wirecard Payment Processing Gateway

  • 56043
  • 3
  • 25
  • 1
  • 0

hiqdev/yii-compat

Yii 2/3 compatibility crutch

  • 57415
  • 2
  • 17
  • 3
  • 0

hexblot/mssql-compat

Small wrapper for PDO that emulates the deprecated mssql_* functions, and allows legacy software to work in PHP7+

  • 70112
  • 0
  • 0
  • 7
  • 2

ducks-project/spl-types

Polyfill Module for SplType PHP extension. This extension aims at helping people making PHP a stronger typed language and can be a good alternative to scalar type hinting. It provides different typehandling classes as such as integer, float, bool, enum and string

  • 71847
  • 0
  • 0
  • 6
  • 1

bit3/contao-compat

Compat layer to work around differences in the Contao 2 and Contao 3 API.

  • 76512
  • 3
  • 0
  • 0
  • 0

Built with Laravel by psampaz, powered by DigitalOcean